Forum AmigaOne Zone

Forum użytkowników Amigi i nie tylko
Teraz jest środa, 15 sie 2018, 22:45

Strefa czasowa: UTC + 1 [ DST ]




Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 5 ] 
Autor Wiadomość
PostNapisane: wtorek, 8 maja 2018, 12:28 
Offline
Znamienity forumowicz
Znamienity forumowicz
Avatar użytkownika

Dołączył(a): wtorek, 17 sty 2012, 13:28
Posty: 1042
Tak sobie coś dłubię na temat zapowiadanej książki i jest to okazja do uruchamiania i używania rzeczy niedotykanych dawno przeze mnie.
Utknąłem w rzeczach podstawowych. Pierwsze dwie wątpliwości.

1. Edytor ikon (systemowy)
Po uruchomieniu zamraża system, konieczny jest twardy reset. Konsultowałem to z innym użytkownikiem OS 4 - jemu działa, ale wczytane ikonki mają przekłamania kolorów. Jak z tym jest u was?
2. Po zabawach z tematami WB został mi inny kursor. Próbowałem go zmienić z poziomu Prefs -> Pointer i nic się nie dzieje. Wiem, jakie są nazwy plików i wiem o katalogu sys:env:archive, ale.. no właśnie jak to zrobić, żeby zmiana zadziałała?


Udostępnij dla FacebookUdostępnij dla TwitterUdostępnij dla Google+
Góra
 Zobacz profil Wyślij prywatną wiadomość  
Cytuj  
PostNapisane: wtorek, 8 maja 2018, 20:49 
Offline
Administrator
Administrator
Avatar użytkownika

Dołączył(a): poniedziałek, 16 sty 2012, 16:14
Posty: 3130
adam napisał(a):
Tak sobie coś dłubię na temat zapowiadanej książki i jest to okazja do uruchamiania i używania rzeczy niedotykanych dawno przeze mnie.
Utknąłem w rzeczach podstawowych. Pierwsze dwie wątpliwości.

1. Edytor ikon (systemowy)
Po uruchomieniu zamraża system, konieczny jest twardy reset. Konsultowałem to z innym użytkownikiem OS 4 - jemu działa, ale wczytane ikonki mają przekłamania kolorów. Jak z tym jest u was?


IconEdit powinien działać. Trudno mi powiedzieć dlaczego u Ciebie nie działa. Warto jednak zauważyć że nosi numerek 44.20. Jak wiadomo 44 to numeracja dla systemu AmigaOS 3.5 (45.xx = AOS 3.9, 50.xx = AOS 4.0 Pre release, 52.xx, AOS 4.0, 53.xx = AOS 4.1, 54.xx = AOS 4.2). Jest to więc jeden z nielicznych elementów systemu, który nie został przepisany na PowerPC i pomimo daty pliku z okresu obowiązywania AmigaOS 4 28.02.2006, to jest nadal narzędzie dla 68k. Jak wiadomo w czasach AOS 3.5 nikt nie znał standardu ikon dla AmigaOS 4.1 i 4.0 (zresztą pierwsze wersjie Pre release, też miały jeszcze stary standard Glowicon), to też trudno się dziwić że program niepoprawnie rozpoznaje ikony w nieznanym sobie standardzie i przekłamuje kolory.

Jak wiadomo były kiedyś próby zastąpienia systemowego edytora ikon nowym (m. in. kolega Heextreme coś tam próbował robić w ramach bounty) ale nic z tego nie wyszło. Jako że i tak najwygodniej jest używać do tego celu nowoczesnych programów typu Gimp, to nikt tego już potem nie ruszał i myślę że ma to niski priorytet. To narzędzie można więc traktować tylko jako edytor ikon dla starszych wersji systemu, z którymi to standardami jak wiadomo AmigaOS 4 jest kompatybilny w dół.
Na marginesie myślę że taki zamiennik to by była idealna rzecz do dołączenia do pakietu Enhancer Software, napewno bardziej użyteczna niż podróba AmiDocka czy Exchange.


Góra
 Zobacz profil Wyślij prywatną wiadomość  
Cytuj  
PostNapisane: wtorek, 8 maja 2018, 22:41 
Offline
Znamienity forumowicz
Znamienity forumowicz
Avatar użytkownika

Dołączył(a): wtorek, 17 sty 2012, 13:28
Posty: 1042
Cytuj:
Jak wiadomo w czasach AOS 3.5 nikt nie znał standardu ikon dla AmigaOS 4.1 i 4.0 (zresztą pierwsze wersjie Pre release, też miały jeszcze stary standard Glowicon), to też trudno się dziwić że program niepoprawnie rozpoznaje ikony w nieznanym sobie standardzie i przekłamuje kolory.

Rozumiem taką argumentację jak podałeś odnośnie przekłamania kolorów, ale u mnie zamraża się po uruchomieniu bez wczytywania ikon. Na pusto. Jestem zdziwiony że to działa u ciebie, bo system masz jeszcze nowszy.
Czyli to zostawiamy. To poczekam jeszcze na próby z ustawieniem kursora, dopóki tego nie wyjaśnimy to nie będę wyciągał kolejnych rzeczy.


Góra
 Zobacz profil Wyślij prywatną wiadomość  
Cytuj  
PostNapisane: wtorek, 15 maja 2018, 13:54 
Offline
Znamienity forumowicz
Znamienity forumowicz
Avatar użytkownika

Dołączył(a): wtorek, 17 sty 2012, 13:28
Posty: 1042
Czyli rozumiem że nie da się ustawić kursora z poziomu Prefs? Nie chce być oskarżany po publikacji o sianie nieprawdy.


Góra
 Zobacz profil Wyślij prywatną wiadomość  
Cytuj  
PostNapisane: wtorek, 15 maja 2018, 21:59 
Offline
Administrator
Administrator
Avatar użytkownika

Dołączył(a): poniedziałek, 16 sty 2012, 16:14
Posty: 3130
adam napisał(a):
Czyli rozumiem że nie da się ustawić kursora z poziomu Prefs? Nie chce być oskarżany po publikacji o sianie nieprawdy.


32-bitowe kursory wprowadzono wraz systemem AmigaOS 4.0 FE, a więc lat już temu 12. Jako że ja co do zasady mie zwykłem zmieniać tematów WB, czy samych kursorów, to też nie bardzo mam papiery na jednoznaczną odpowiedź w tej kwestii. Jednakże o ile czegoś nie pomyliłem i o ile pamięć mnie nie zawodzi, to od początku było tak że musiałeś po prostu przekopiować samemu def_pointer do odpowiedniego katalogu w sys:prefs/env. Wydaje mi się przy tym że nadal zachowano możliwość stosowania klasycznego pointera, którego możesz zapisać po staremu z preferencji wskaźnika.

Szczerze powiedziawszy nie mam teraz czasu by przyjrzeć się sprawie i samemu to zweryfikować, bo niemal ustawicznie ostatnio siedzę w pracy (teraz też), może w niedzielę uda mi się przysiąść do Amigi na godzinę czy dwie.


Góra
 Zobacz profil Wyślij prywatną wiadomość  
Cytuj  
Wyświetl posty nie starsze niż:  Sortuj wg  
Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 5 ] 

Strefa czasowa: UTC + 1 [ DST ]


Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 3 gości


Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Skocz do:  
cron
Powered by phpBB® Forum Software © phpBB Group
Przyjazne użytkownikom polskie wsparcie phpBB3 - phpBB3.PL
phpBB SEO