Forum AmigaOne Zone

Forum użytkowników Amigi i nie tylko
Teraz jest piątek, 20 paź 2017, 01:29

Strefa czasowa: UTC + 1 [ DST ]




Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 40 ]  Przejdź na stronę Poprzednia strona  1, 2, 3
Autor Wiadomość
PostNapisane: wtorek, 21 lut 2017, 20:22 
Offline
Administrator
Administrator
Avatar użytkownika

Dołączył(a): poniedziałek, 16 sty 2012, 16:14
Posty: 2748
A wracając do samego Emotion, to wykryłem jeden błąd. Przy czym nie dziwię się że autorom umknął ten błąd bo takich filmów się normalnie nie spotyka. Mianowicie Emotion nie potrafi w normalnym tempie wyśiwetlać filmów o klatkowaniu 1fps (przynajmniej w przypadku kodeka ZMBV) po prostu odtwarza je w dużym przyspieszeniu, w przypadku 2fps jest już ok. Nadmieniam że Mplayer-MUI odtwarza takie filmy w nominalnym tempie jednej klatki na sekundę. No ale to taka ciekawostka.


Udostępnij dla FacebookUdostępnij dla TwitterUdostępnij dla Google+
Góra
 Zobacz profil  
Cytuj  
PostNapisane: wtorek, 21 lut 2017, 22:38 
Offline
Elitarny forumowicz
Elitarny forumowicz

Dołączył(a): wtorek, 17 sty 2012, 21:57
Posty: 661
Mufa napisał(a):
...i z góry zapowiadam iż nie omieszkam sobie odmówić przyjemności wyszukania w swoim czasie wątków na forum o tym kto wątpił, a kto nie ;) .


Ależ nie chodzi o to czy, tylko kiedy? Lista, którą wymieniłem powoli jest realizowana. Wiemy, że powstaje LO, Gutenprint. Shadery już są. Tylko, że to zajmuje lata. Dlatego przedwczesne ekscytowanie się jest raczej szkodliwe ;) I w tym wypadku (UVD) to już nie jest "kilka miesięcy". Swoją drogą 90% procent (a może 100%) realizuje AEon...

Ale żeby nie było, naprawdę się cieszę, że coś się w końcu dzieje :)

_________________
SAM440 Flex 800MHz 1GB R9250 SBLive! OS4.1 FE


Góra
 Zobacz profil  
Cytuj  
PostNapisane: wtorek, 21 lut 2017, 23:17 
Offline
Elitarny forumowicz
Elitarny forumowicz
Avatar użytkownika

Dołączył(a): piątek, 20 sty 2012, 23:31
Posty: 536
Odnośnie błędów w Emotion, zauważyłem że gdy przesuwam suwak głośności to poziom dźwięku
zmienia się dopiero po "upuszczeniu" suwaka. Nie sprawdzałem czy taka uroda AOSa czy tylko Emo tak ma.

Nawiązując do UVD i tego co robi Hans. Nie wiem nad czym aktualnie pracuje bo nikt nie puszcza pary z ust,
ale moim bardzo skromnym zdaniem powinni postarać się w końcu o to żeby te wypasione karty graficzne
zaprząc do pracy poważniejszej niż dotąd, chociażby do sprzętowego odtwarzania filmów.
Ba mam wrażenie że na razie to taka sztuka dla sztuki, szejdery są fajne ale póki co korzyść z nich mierna,
a sprzętowe wsparcie dla oglądania filmów było by dostępne dla każdego. Nie wiem czy oni mają jakiś
plan na dłuższą metę, odnośnie obsługi i wykorzystania kart graficznych włączając dźwięk, którego nie ma wcale,
a co dość ważne w świetle odkrycia problemów z kartami dźwiękowymi na PCI(e). Powinni dać gawiedzi
możliwość wygodnego oglądania filmów a w tym czasie robić API i wykorzystać je do tworzenia oprogramowania
pod W3DN. Z drugiej strony jeśli Hans sam się tym zajmuje to wiele nie nar... obi ;).

Oczywiście nie ma co wymagać cudów, swinkamor12 dobrze to ujął, cieszmy się tym co mamy i tyle ile zdołamy.
Kupując oprogramowanie najlepiej wskażemy gdzie powinna iść cała para i uwaga programistów, z tego też powodu
nie kupiłem Enhancera, ładny zegar to trochę za mało a ponadto mogłoby zmylić Trevora że to dobry trop i to będą
rozwijać bo ludzie lubią fajne bajery na blacie. Oczywiście jest tam więcej niż tylko ładny zegar, ale jak dla mnie
szkoda czasu programistów na takie bzdety. Pomijając W3D w tym pakiecie, szkoda tylko że zapłaciłem za sam W3D
połowę ceny Enhancera z tymże...

_________________
AmigaOne X5000/020, Sapphire Radeon R9 270X Toxic, 2GB RAM.
Amiga1200/060 32MB RAM
Obrazek


Góra
 Zobacz profil  
Cytuj  
PostNapisane: środa, 22 lut 2017, 00:09 
Offline
Elitarny forumowicz
Elitarny forumowicz

Dołączył(a): wtorek, 17 sty 2012, 21:57
Posty: 661
Cytuj:
Nie wiem czy oni mają jakiś
plan na dłuższą metę, odnośnie obsługi i wykorzystania kart graficznych włączając dźwięk, którego nie ma wcale,
a co dość ważne w świetle odkrycia problemów z kartami dźwiękowymi na PCI(e)


Masz na myśli dźwięk po HDMI? Ten był w planach Hansa. Pisał kiedyś (dwa lata temu?) o tym na Amigans. Musi być coś więcej w planach dotyczących GPU. Taki Tabor sporo by na tym zyskał....

_________________
SAM440 Flex 800MHz 1GB R9250 SBLive! OS4.1 FE


Góra
 Zobacz profil  
Cytuj  
PostNapisane: środa, 22 lut 2017, 07:12 
Offline
Administrator
Administrator
Avatar użytkownika

Dołączył(a): poniedziałek, 16 sty 2012, 16:14
Posty: 2748
Suwaczek głośności w innych odtwarzaczach działa w czasie rzeczywistym. Natomiast co do kart graficznych, nikt nie składa broni. Pracuje Hans, pracuje Daniel, pewne fajnie rzeczy które się dokonały, zostaną pewnie ogłoszone lub poznacie w następnym wydaniu Enhancer.


Góra
 Zobacz profil  
Cytuj  
PostNapisane: środa, 22 lut 2017, 23:55 
Offline
Elitarny forumowicz
Elitarny forumowicz

Dołączył(a): wtorek, 17 sty 2012, 21:57
Posty: 661
Przemek napisał(a):
Pisał kiedyś (dwa lata temu?) o tym na Amigans.


Byłem ciekaw jak moja percepcja upływu czasu i tu niespodzianka. Ta cała gadka o UVD z Hansem była w kwietniu 2013!!! To już cztery lata :o

_________________
SAM440 Flex 800MHz 1GB R9250 SBLive! OS4.1 FE


Góra
 Zobacz profil  
Cytuj  
PostNapisane: czwartek, 23 lut 2017, 00:30 
Offline
Elitarny forumowicz
Elitarny forumowicz
Avatar użytkownika

Dołączył(a): piątek, 20 sty 2012, 23:31
Posty: 536
Trochę miałem czasu żeby głębiej zajrzeć w Emotion i tak:
Ma kilka fajnych możliwości, dla przykładu chowanie ramki okna "b",
albo wyświetlanie rodzaju odtwarzanego wideo i audio. Opcja
dopasowywania wielkości okna -skrót "w" - nie działa chyba tak jak powinna.
Spodziewałbym się że okno zostanie rozciągnięte do rodzielczości filmu,
a ona poprostu dopasowuje okno tak że niewidać czarnego tła które jest widoczne
gdy okno Emo ma inne proporcje niż odtwarzany film. Taki przycisk "100%", przy okazji
zastanawiam się czy brak skalowania wpłynąłby na wydajność odtwarzania.
Poza tym szkoda że lista ostatnio odtwarzanych plików ma tylko pięć pozycji.
Skrót "ESC" powinien zatrzymać odtwarzanie a nie robi nic.

Testowałem na filmie nagranym przeze mnie dawno temu w Azeroth:
H.264/AVC/MPEG-4 AVC/ MPEG-4 Part 10 (1280x720/24) a dźwięk AAC.
Ogólnie zajętość procesora wacha się od 49 do 100%, pomijanie klatek wyłączone
filtr "f" zdaje się nie mieć żadnego wpływu na szybkość, jedynie rozmywa ostre krawędzie.
Natomiast film nagrany aparatem 1440x1080/25, reszta taka sama jak w poprzednim filmie,
powoduje zajętośc 100% non stop i dopiero przy frame skip 2 dźwięk się nie rwie ani trochę,
przy 1 i 0, rwię się dość często.
A przepraszam, przy frame skip 3 zajętość procka spada miejscami do 87%, wartość 4 zdaje się
nie robić różnicy.

Ciekawy jestem jak to wygląda na X1000 i u innych użytkowników X5000.

_________________
AmigaOne X5000/020, Sapphire Radeon R9 270X Toxic, 2GB RAM.
Amiga1200/060 32MB RAM
Obrazek


Góra
 Zobacz profil  
Cytuj  
PostNapisane: czwartek, 23 lut 2017, 01:42 
Offline
Elitarny forumowicz
Elitarny forumowicz
Avatar użytkownika

Dołączył(a): piątek, 20 sty 2012, 23:31
Posty: 536
Jednej rzeczy nie potrafiłem zrobić, a mianowicie na filmie z pierwszej strony tego wątku,
w 50 sekundzie widać jak nagrywający w chodzi w Odysseyu na YT i klika prawym na klawiszem
na linku do filmu i pojawia mu się menu kontekstowe z pozycją nazwaną open with YT, czy oni sobie sami
dopisali coś w konfiguracji menu kontekstowego OWB, czy ja mam jakąś lewą wersję tej przeglądarki
czy jeszcze coś innego jest u mnie powodem braku takiej pozycji?

W prefsach OWB w MIME zmieniłem sobie kilka video na przeglądarkę zewnętrzną - Emotion - ale dalej nic.

_________________
AmigaOne X5000/020, Sapphire Radeon R9 270X Toxic, 2GB RAM.
Amiga1200/060 32MB RAM
Obrazek


Góra
 Zobacz profil  
Cytuj  
PostNapisane: czwartek, 23 lut 2017, 07:13 
Offline
Administrator
Administrator
Avatar użytkownika

Dołączył(a): poniedziałek, 16 sty 2012, 16:14
Posty: 2748
Wydaje mi się że w przypadku YouTube i Odyssey, może chodzić o program YT (jest takie coś na OS4Depot). Filmy bez ramki to już DvPlayer potrafił wyświetlać. Co do testów, to chyba najlepiej byłoby wziąć jakiś film z YT, pobrać go z takimi samymi parametrami SmTube i wtedy porównywać, bo film filmowi nierówny.

Ogólnie to mam nadzieję że Emotion pomimo swoich wad sprzedał się przynajmniej w zakładanej przez autorów liczbie 100 sztuk, bo to będzie gwarantowało konkretny rozwój, a nie tylko poprawki.


Góra
 Zobacz profil  
Cytuj  
PostNapisane: czwartek, 23 lut 2017, 17:09 
Offline
Elitarny forumowicz
Elitarny forumowicz
Avatar użytkownika

Dołączył(a): piątek, 20 sty 2012, 23:31
Posty: 536
Ja też mam taką nadzieję, bo przypasował mi ten program, bez zbędnych wodotrysków, ma robić to co ma i robić dobrze.
Chciałbym żeby Hans, albo ktokolwiek kto jest w stanie, zrobił sprzętowe wspomaganie dekodowania filmów.
Choć patrząc na ten film, mam wrażenie że X5000 potrzebuje jeszcze sporo optymalizacji, bo na ich X1000
chodzi to lepiej.

_________________
AmigaOne X5000/020, Sapphire Radeon R9 270X Toxic, 2GB RAM.
Amiga1200/060 32MB RAM
Obrazek


Góra
 Zobacz profil  
Cytuj  
Wyświetl posty nie starsze niż:  Sortuj wg  
Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 40 ]  Przejdź na stronę Poprzednia strona  1, 2, 3

Strefa czasowa: UTC + 1 [ DST ]


Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 3 gości


Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Skocz do:  
Powered by phpBB® Forum Software © phpBB Group
Przyjazne użytkownikom polskie wsparcie phpBB3 - phpBB3.PL
phpBB SEO