Forum AmigaOne Zone

Forum użytkowników Amigi i nie tylko
Teraz jest niedziela, 15 wrz 2019, 16:12

Strefa czasowa: UTC + 1 [ DST ]




Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 20 ]  Przejdź na stronę 1, 2  Następna strona
Autor Wiadomość
PostNapisane: środa, 1 lut 2012, 19:53 
Offline
Administrator
Administrator
Avatar użytkownika

Dołączył(a): poniedziałek, 16 sty 2012, 16:14
Posty: 3515
No więc obiecałem swego czasu na eXecu Recendentowi że skonfrontuję X1000 z jego benchmarkami. Nie mam już jednak tam konta, jak i nie mam na PPA. Więc postaram się umieszczać wyniki w tym wątku. oczywiście wszystkich benchmarków porównać nie dam rady, choćby dlatego że nie mam 3D i overlaya, a niektóre z testowanych tam rzeczy są wyłącznie w wersji dla Morphosa. Zaznaczam że wszystkie testy dotycza jednego rdzenia procesora i są rzecz jasna wykonywane na nie do końca zoptymalizowanym pod X1000 AmigaOS 4.1 Update 5. Na dzień dzisiejszy pierwszy benchmark - Lame:
http://www.apc74.ppa.pl/PPA/Efika_vs_re ... tml#table8
Obrazek


Udostępnij dla FacebookUdostępnij dla Twitter
Góra
 Zobacz profil  
Cytuj  
PostNapisane: czwartek, 2 lut 2012, 13:43 
Offline
Doborowy forumowicz
Doborowy forumowicz

Dołączył(a): wtorek, 17 sty 2012, 21:57
Posty: 828
Rafal, czy ten test byl zrobiony z Altivec? Bo podlinkowalem Twoj wynik i pytaja czy wer na MOSa i AOS byla wlasnie pod niego :-) Na AW pojawily sie ciekawe wyniki. Szybkosc pamieci miazdzy :-D

_________________
SAM440 Flex 800MHz 1GB R9250 SBLive! OS4.1 FE


Góra
 Zobacz profil  
Cytuj  
PostNapisane: czwartek, 2 lut 2012, 16:22 
Offline
Administrator
Administrator
Avatar użytkownika

Dołączył(a): poniedziałek, 16 sty 2012, 16:14
Posty: 3515
Przemek napisał(a):
Rafal, czy ten test byl zrobiony z Altivec? Bo podlinkowalem Twoj wynik i pytaja czy wer na MOSa i AOS byla wlasnie pod niego :-) Na AW pojawily sie ciekawe wyniki. Szybkosc pamieci miazdzy :-D


No oczywiście, czemu miałbym używać innej, skoro mój proc wykorzystuje Altiveca, co do MOSa to mnie nie pytaj, ale zakładam że w przypadku maszyn z G4 też.


Góra
 Zobacz profil  
Cytuj  
PostNapisane: czwartek, 2 lut 2012, 17:52 
Offline
Administrator
Administrator
Avatar użytkownika

Dołączył(a): poniedziałek, 16 sty 2012, 16:14
Posty: 3515
Mufa napisał(a):
No więc obiecałem swego czasu na eXecu Recendentowi że skonfrontuję X1000 z jego benchmarkami. Nie mam już jednak tam konta, jak i nie mam na PPA. Więc postaram się umieszczać wyniki w tym wątku. oczywiście wszystkich benchmarków porównać nie dam rady, choćby dlatego że nie mam 3D i overlaya, a niektóre z testowanych tam rzeczy są wyłącznie w wersji dla Morphosa. Zaznaczam że wszystkie testy dotycza jednego rdzenia procesora i są rzecz jasna wykonywane na nie do końca zoptymalizowanym pod X1000 AmigaOS 4.1 Update 5. Na dzień dzisiejszy pierwszy benchmark - Lame:
http://www.apc74.ppa.pl/PPA/Efika_vs_re ... tml#table8
Obrazek


No i kolejny teścik z tamtej stronki, tym razem kopiowanie:

Obrazek

Ogólnie myślę że są tutaj jeszcze rezerwy. przynajmniej ja jeszcze w czasach przed update 5 miałem około 10% lepsze przy kopiowaniu do ramu i dużo dużo lepsze przy kopiowaniu z partycji na partycję. Nie wiem czemu teraz to się pogorszyło, no ale trudno podaję to co mi aktualnie wychodzi.


Góra
 Zobacz profil  
Cytuj  
PostNapisane: czwartek, 2 lut 2012, 17:58 
Offline
Aktywny forumowicz
Aktywny forumowicz
Avatar użytkownika

Dołączył(a): wtorek, 17 sty 2012, 17:19
Posty: 277
Lokalizacja: Podbeskidzie
To tak jak Kowalczyk i Bjoergen :lol:

_________________
CommodorOwca
A4000D CVISION PPC/A1200 BVISION PPC
A1200 060/Sam 460ex/C128D
W oczekiwaniu na Amigę 4000T


Góra
 Zobacz profil  
Cytuj  
PostNapisane: czwartek, 2 lut 2012, 19:26 
Offline
Regularny forumowicz
Regularny forumowicz

Dołączył(a): poniedziałek, 23 sty 2012, 09:17
Posty: 59
Testy LAME podane na stronie "Efika vs reszta świata" zostały dla MorphOSa wykonane wersją LAME nie wykorzystującą AltiVeca. Dla wersji AltiVecowej wyniki wyglądają następująco (program można pobrać z Aminetu):

Mój Mac mini 1,42 GHz wykonuje test w 18 sekund (MorphOS 2.7 wersja publiczna).
PowerBook 1,67 GHz Harry'ego Sintonena robi ten test w 16 sekund, z tym, że na niepublicznej wersji MorphOSa 3.0.

O ile jest zainteresowanie, mogę zrobić testy na Pegasosie 2 i PowerMacu 500 MHz.


Góra
 Zobacz profil  
Cytuj  
PostNapisane: czwartek, 2 lut 2012, 21:26 
Offline
Administrator
Administrator
Avatar użytkownika

Dołączył(a): poniedziałek, 16 sty 2012, 16:14
Posty: 3515
G. Kraszewski napisał(a):
na niepublicznej wersji MorphOSa 3.0.


Testy na niepublicznych wersjach nie mają żadnego znaczenia, bo są nieweryfikowalne przez przeciętnego usera. Testy na X1000 z publicznym AmigaOS 4.1 U5, może potwierdzić na dziś jak mniemam ze sto kilkadziesiąt osób. Jak już wyjdzie ten MOS, to może i będzie AmigaOS 4.2, wówczas się porówna.

Cytuj:
O ile jest zainteresowanie, mogę zrobić testy na Pegasosie 2 i PowerMacu 500 MHz.


Ja jestem zainteresowany testami na Pegasosie, przy czym preferowałbym wyniki w wersji Lame dla AmigaOS 4. Jak masz czas prosiłbym też o przetestowanie tego czegoś. uruchamiamy systemowego stopera (instrukcja postępowania tutaj), odpalamy prezentację z shella i notujemy czas trwania.


Góra
 Zobacz profil  
Cytuj  
PostNapisane: czwartek, 2 lut 2012, 21:38 
Offline
Doborowy forumowicz
Doborowy forumowicz

Dołączył(a): wtorek, 17 sty 2012, 21:57
Posty: 828
Rafal, moglbys zrobic jeszcze raz test Lame BEZ Altivec? Bez wykresu, sam wynik...

EDIT: Wyglada na to, ze wer. dla OS4 nie ma jednak Altiveca...

_________________
SAM440 Flex 800MHz 1GB R9250 SBLive! OS4.1 FE


Góra
 Zobacz profil  
Cytuj  
PostNapisane: czwartek, 2 lut 2012, 21:50 
Offline
Regularny forumowicz
Regularny forumowicz

Dołączył(a): poniedziałek, 23 sty 2012, 09:17
Posty: 59
Mufa napisał(a):
Jak już wyjdzie ten MOS, to może i będzie AmigaOS 4.2, wówczas się porówna.
LAME testuje głównie wydajność procesora i pamięci. MorphOS 3.0 niewiele będzie w stanie tu zmienić, co do AmigaOS 4.2 to trudno mi, rzecz jasna, cokolwiek powiedzieć.
Mufa napisał(a):
Ja jestem zainteresowany testami na Pegasosie, przy czym preferowałbym wyniki w wersji Lame dla AmigaOS 4. Jak masz czas prosiłbym też o przetestowanie tego czegoś. uruchamiamy systemowego stopera (instrukcja postępowania tutaj), odpalamy prezentację z shella i notujemy czas trwania.
Pegasos stoi w pracy, a więc jutro.


Góra
 Zobacz profil  
Cytuj  
PostNapisane: piątek, 3 lut 2012, 11:03 
Offline
Regularny forumowicz
Regularny forumowicz

Dołączył(a): poniedziałek, 23 sty 2012, 09:17
Posty: 59
AmigaOS 4.1 na Pegasosie 2, 1,0 GHz, plik AKsack.wav, ustawienia domyślne.
LAME bez akceleracji AltiVecem: 45 sekund.
LAME z akceleracją AltiVecem: 24 sekundy.
Program LAME pobrałem z OS4Depot. Teraz wezmę się za test z Hollywood.
... później ...
Test Hollywood wykonuje się na Pegasosie 2 27,4 sekundy, rozbieżności z kilku wykonań nie przekraczają 0,05 s. Test uruchamiałem z ramdysku.


Góra
 Zobacz profil  
Cytuj  
PostNapisane: piątek, 3 lut 2012, 11:57 
Offline
Amator
Amator
Avatar użytkownika

Dołączył(a): piątek, 3 lut 2012, 11:11
Posty: 15
Zrobiłem na moich makach (wszystkich dwóch) test, i tak:
- G4 450 MHz (AGP Graphics z 1999 roku) - 50s
- G4 933 MHz (Quicksilver z 2001 roku, podkręcony z bodajże 800) - 28s.

Na obu MorphOS 2.7 niezarejestrowany, na tym szybszym jeszcze wrzucony Ultimate Pack (upiększacze i różne cudeńka).


Góra
 Zobacz profil  
Cytuj  
PostNapisane: piątek, 3 lut 2012, 15:50 
Offline
Administrator
Administrator
Avatar użytkownika

Dołączył(a): poniedziałek, 16 sty 2012, 16:14
Posty: 3515
Przemek napisał(a):
Rafal, moglbys zrobic jeszcze raz test Lame BEZ Altivec? Bez wykresu, sam wynik...

EDIT: Wyglada na to, ze wer. dla OS4 nie ma jednak Altiveca...


To była wersja z Altivecem, bo zwykła wersja daje słabsze wyniki. Co prawda w archiwum jest to nazwane jako wersja dla G4 ale to poniekąd to samo. Inna sprawa że to stary program z 2008r. Przydałaby się jakaś nowa kompilacja, utworzona pod najnowszym SDK, być może jakoś dostosowana do procka P.A Semi. Jak juz pisałem na samym początku, to nie jest jeszcze kernel który docelowo pojawi się w AOS 4.2, nie wszystkie rzeczy są zoptymalizowane, działa tylko jeden rdzeń itp. Jednakowoż niektórzy niebiescy już ogłosili światu że X1000 jest w tyle za makówkami. Dlatego nie będę już podawał żadnych wyników, aby nie wzbudzac niepotrzebnych propagandowych wojenek. Zainteresowani mogą pojawić się 25 lutego w Warszawie.


Góra
 Zobacz profil  
Cytuj  
PostNapisane: piątek, 3 lut 2012, 15:54 
Offline
Administrator
Administrator
Avatar użytkownika

Dołączył(a): poniedziałek, 16 sty 2012, 16:14
Posty: 3515
G. Kraszewski napisał(a):
AmigaOS 4.1 na Pegasosie 2, 1,0 GHz, plik AKsack.wav, ustawienia domyślne.
LAME bez akceleracji AltiVecem: 45 sekund.
LAME z akceleracją AltiVecem: 24 sekundy.
Program LAME pobrałem z OS4Depot. Teraz wezmę się za test z Hollywood.
... później ...
Test Hollywood wykonuje się na Pegasosie 2 27,4 sekundy, rozbieżności z kilku wykonań nie przekraczają 0,05 s. Test uruchamiałem z ramdysku.


Dziękuję za testy, widze po tych wynikach że procentowa różnica między Pegiem a X1000 z Altivecem i bez dosyć istotnie się różni. Jestem przekonany że Altivecu dla P.A Semi tkwią jeszcze rezerwy, których AmigaOS 4.1 nie jest w tym momencie w stanie w pełni wykorzystać.


Góra
 Zobacz profil  
Cytuj  
PostNapisane: sobota, 4 lut 2012, 12:07 
Offline
Administrator
Administrator
Avatar użytkownika

Dołączył(a): poniedziałek, 16 sty 2012, 16:14
Posty: 3515
Jeszcze jedna rzecz, serwis amiganews.de sfałszował benchmark przy którym zamieścił moją ksywkę. Moje porównanie z makami opierało się na wynikach zamieszczonych przez samych morphosowców tutaj. Dziwna sprawa że nagle ni stąd ni zowąd wyniki dla Maca poprawiły się o 100%, znacznie nawet dziwniejsza od pozostałych wyników zamieszczanych na wykresach przez fanów MOSa, które róznią się od tego co ludzie podają na forach (Krashan mówił o 16s dla PB pod lame, na wykresie było 15, ktoś na forum AW ktoś pisał o 19s dla MacaMini, na wykresie pojawiło się 17s).


Góra
 Zobacz profil  
Cytuj  
PostNapisane: sobota, 4 lut 2012, 14:11 
Offline
Regularny forumowicz
Regularny forumowicz

Dołączył(a): poniedziałek, 23 sty 2012, 09:17
Posty: 59
Mufa napisał(a):
Dziwna sprawa że nagle ni stąd ni zowąd wyniki dla Maca poprawiły się o 100%
Ja w tym nie widzę nic dziwnego. Jeżeli najpierw podano wyniki dla LAME nie akcelerowanego AltiVecem (takie wyniki były na stronie "Efika vs reszta świata"), a później zrobiono testy LAME akcelerowanym, to wyniki się poprawiają. Nawet o 100 procent. Zrób na X1000 test LAME z akceleracją i bez akceleracji, sam zobaczysz.
Mufa napisał(a):
Krashan mówił o 16s dla PB pod lame, na wykresie było 15
Ta różnica wzięła się z tego, że Piru zrobił test innym plikiem WAVE. Tych testów w sieci jest sporo i początkowo wziął plik używany w testach przez Tuxedo na AmigaWorld.net. AKsack.wav jest krótszy, stąd poprawa wyniku o sekundę.
Mufa napisał(a):
ktoś na forum AW ktoś pisał o 19s dla MacaMini, na wykresie pojawiło się 17s.
Mac mini występuje w czterech odmianach prędkościowych od 1,25 do 1,5 GHz. Jeżeli mówimy o wynikach dla mini, musimy więc podać zegar procesora. Mini 1,42 GHz kompresuje AKsack.wav w 18 sekund, zapraszam do sprawdzenia na AmiWawie.

Warto jeszcze wspomnieć, że wyniki testów sprawdzające szybkość kopiowania plików zależą od wielu czynników, np. systemu plików na partycji, a także stopnia fragmentacji. Dlatego testy kopiowania gdzie albo źródło, albo cel jest czymś innym niż RAM:, będą miały zawsze duży rozrzut i do końca nie wiadomo, co tak naprawdę mierzą.


Góra
 Zobacz profil  
Cytuj  
Wyświetl posty nie starsze niż:  Sortuj wg  
Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 20 ]  Przejdź na stronę 1, 2  Następna strona

Strefa czasowa: UTC + 1 [ DST ]


Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 1 gość


Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Skocz do:  
cron
Powered by phpBB® Forum Software © phpBB Group
Przyjazne użytkownikom polskie wsparcie phpBB3 - phpBB3.PL
phpBB SEO