Forum AmigaOne Zone

Forum użytkowników Amigi i nie tylko
Teraz jest sobota, 23 paź 2021, 18:35

Strefa czasowa: UTC + 1




Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 41 ]  Przejdź na stronę 1, 2, 3  Następna strona
Autor Wiadomość
PostNapisane: środa, 9 gru 2020, 19:24 
Offline
Znamienity forumowicz
Znamienity forumowicz

Dołączył(a): wtorek, 17 sty 2012, 20:57
Posty: 1058
Jako, że krótkie dnie sprzyjają grzebaniu w starym hobby postanowiłem przyjrzeć się, czy niewielkim kosztem można jeszcze coś wycisnąć z mojej leciwej SAM440 Flex? Skłoniła mnie do tego ostatnia aktywność firmy ACube

http://www.acube-systems.biz/index.php?page=news#archive

Po ponad 10 latach programiści z tej firmy nadal wspierają swoją płytę główną, niesamowite! Tym razem dostarczyli uaktualnienie firmware, które ma na celu umożliwić takim amigowcom jak ja, wyciśnięcie ostatnich soków z tej leciwej konstrukcji. Wprawdzie kiedyś podobne uaktualnienie miało już otworzyć nam drogę do użycia nowych kart graficznych jednak szybko okazało się, że system nie widzi kart "schowanych" za niezbędnym adapterem PCI->PCI Express. Moja SAM nie posiada niestety złącza PCI Express. Stąd konieczność zastosowania ww. adaptera. Co istotne musi być on oparty o chip PEX8112 lub PI7C9X. Wcześniej mówiło się również o PEX8111 ale autorzy nowego firmware już o nim nie wspominają.
Mam wrażenie, że wspomniane uaktualnienie nie pojawiło się przypadkiem. Gigantyczne opóźnienia związane z Taborem powodują, że coraz więcej fanów rozgląda się za konkurencją a brak nowych użytkowników uczyni finansowanie nadchodzącego pakietu Enhancer 2.0 jeszcze trudniejszym. Stąd pomysł wyciśnięcia gotówki z użytkowników sprzętu, o którym AEon już dawno chciałby zapomnieć ;) Do tego ostatnie zacieśnienie współpracy między AEon i ACube nie pozostawia wątpliwości, jaki jest cel tego ruchu? Ale dobrze, niech im będzie. Użytkownicy, jak ja, którzy nie chcą/nie mogą zmienić swojej Amigi na nowszą, za relatywnie niewielkie pieniądze będą mogli zakosztować świata nowoczesnych kart graficznych. Oby! Mam bowiem wątpliwości, czy nie pojawią się jakieś problemy. Ale na początek bezbolesna i darmowa aktualizacja poszła sprawnie. Później skuszony postem innego użytkownika i sugestią bezpośrednio z ACube, że oto, ten adapter się nada, złożyłem zamówienie.

https://www.aliexpress.com/item/4000764714110.html?af=843361&utm_campaign=843361&aff_platform=portals-tool&utm_medium=cpa&dp=b334121598d86f7de15fd384d380fe03&cv=47843&mall_affr=pr3&sk=_ePNSNV&aff_trace_key=4d8f866edef14917a4e599328bc8a859-1607284001363-08918-_ePNSNV&terminal_id=e19630c607e746d6a069ebf5137c0da2&tmLog=new_Detail&utm_source=admitad&utm_content=47843

Ponieważ koszt całego przedsięwzięcia to na razie niecałe 80 zł, ewentualne niepowodzenie nie będzie bardzo bolesne. Niestety muszę zaczekać 12 dni ale to i tak ogromny postęp i chyba nowa, transsyberyjska linia z Chin, przyczyniła się do skrócenia czasu oczekiwania z 30 dni.
W międzyczasie powinien pojawić się mityczny ES2.0 ze wsparciem UVD a może uda mi się wydobyć jakieś informacje o ewentualnym, testowym sterowniku? Kupowanie ww. pakietu za prawie 400 zł tylko po to żeby się przekonać, że coś nie działa nie jest miła perspektywą.
Na koniec chcę jeszcze tylko zaznaczyć, że moim celem nie jest granie w jakieś wymagające gry. W związku z moimi różnymi aktywnościami przeróżne filmiki są codziennością. Ich jakość jest coraz większą a biedna SAM potrafi sobie poradzić jedynie z rozdzielczością 240p. Niewiele filmów można wyświetlić w tej jakości a z kolei nasza "zaawansowana" przeglądarka nie jest także w stanie zmusić YuoTuba do takiego wysiłku. Dlatego wspomaganie dekodowania filmów jest u mnie na pierwszym miejscu. Nie byłoby całego tego kombinowania gdyby dostępny był oczywiście inny sprzęt niż AOne X5000 ale to już wszyscy wiemy:-) ... Do usłyszenia ;-)

_________________
SAM440 Flex 800MHz 1GB R9250 SBLive! OS4.1 FE


Udostępnij dla FacebookUdostępnij dla Twitter
Góra
 Zobacz profil  
Cytuj  
PostNapisane: sobota, 26 gru 2020, 22:50 
Offline
Znamienity forumowicz
Znamienity forumowicz

Dołączył(a): wtorek, 17 sty 2012, 20:57
Posty: 1058
Zaledwie po 14 dniach od zamówienia rzeczony adapter pojawił się u mnie na biurku. Iście ekspresowe tempo. Niestety żeby nie było kolorowo chip, o który jest oparty nie jest tym samym, który widniał w opisie. Zamiast PEX8112 wlutowany jest PEX8111. Ewidentna niezgodność z opisem. Wprawdzie na stronie Hansa de Ruitera nadal widnieje jako kompatybilny ale już ACube, w ostatniej aktualizacji Uboota, nie wymienia go na liście. Pomyślałem, że jednak zaczekam z reklamacją bo bardziej zależy mi na szybkim teście. Postanowiłem, w oczekiwaniu na Enhancer 2.0, zainstalować adapter i sprawdzić co się wydarzy. Nie demontując karty graficznej ze złącza 66MHz, włożyłem adapter do wolnego slotu 33MHz i włączyłem komputer. Pierwszy efekt to kompletnie czarny ekran, bez jakiegokolwiek znaku życia. Pomyślałem, że pewnie to już koniec przygody ale po długim czasie (ok. 40 s) wreszcie pojawił się Uboot. Niestety i tenże uruchamia się potwornie długo. Gdy wreszcie kickstart wgrał się, tempo uruchamiania systemy było już takie samo jak kiedyś. Szybki test Rangerem i mam już pewność, że system widzi mostek PCI->PCI Express oparty o kość PEX8111. Niestety za każdym razem gdy użyję twardego resetu proces inicjalizacji sprzętu trwa ok. 90 s dłużej niż przed instalacją mostka. Może to częściowo wina wolniejszego złącza PCI ? Nie wiem. W wątku na Amigans, w którym udzielał się Max z ACube, nikt mi nie odpowiedział. Trzeba będzie drążyć dalej. Ciężkie jest życie testera w tak małym środowisku ;-) Do tego nadal nie pojawił się obiecany Enhancer 2.0. Miałem nadzieję, że jego wydanie da odpowiedzi na kilka pytań. Trzeba uzbroić się znowu w cierpliwość....

_________________
SAM440 Flex 800MHz 1GB R9250 SBLive! OS4.1 FE


Góra
 Zobacz profil  
Cytuj  
PostNapisane: niedziela, 27 gru 2020, 09:43 
Offline
Administrator
Administrator
Avatar użytkownika

Dołączył(a): poniedziałek, 16 sty 2012, 15:14
Posty: 4058
No tak, U-Boot to na szczęście nie CFE, ale i tak nie jest zupełnie wolny ow whań czasu uruchomienia związanego z inicjalizacją urządzeń, w zależności jakie rzeczy (pamięć RAM, karta graficzna itd.) obsadzisz w komputerze. Możliwe że czas się wydłużył bo skoro U-Boot wykrył adapter w slocie PCI, to szuka czegoś co powinno być do niego podpięte powtarzając tę czynność n razy. Tak że nie wykluczam że jeśli już obsadzisz adapter kartą graficzną czas bootowania znowu się skróci.

A co do ES, to Leaman ze wstydu powinien schować się pod stół. No bo jak na jesień wyszedł ten słynny wątek na amigans.net związany z niezadowoleniem ludzi z powodu działalności amifirm, ten zachowywał się bardzo nie fair stosując metodę spychologii. Kilka razy się wybielał że jego firma jest cool i wskazywał palcem na Hyperion, że to do nich ludzie powinni mieć pretensje. A koniec końców wyszło na to że Hyperion się spisał, a A-EON po raz kolejny nie dotrzymal zapowiedzi. Aż mam ochotę odświeżyć ten wątek i mu co nieco napisać.


Góra
 Zobacz profil  
Cytuj  
PostNapisane: niedziela, 27 gru 2020, 10:51 
Offline
Znamienity forumowicz
Znamienity forumowicz

Dołączył(a): wtorek, 17 sty 2012, 20:57
Posty: 1058
Postaram się niebawem coś wcisnąć w ten adapter. Czekałem na wyjście ES2.0 i wtedy chciałem powalczyć o sterownik lite. Skoro mam działającego R9250 to po włożeniu jakiejś karty w adapter obejrzę sobie, co tam Ranger będzie widział.
Może po aktualizacji Hyperionu zrobił się jakiś problem z Enhancerem? Leaman jest bardzo krytykowany za to samo nazewnictwo zamienników systemowych. Sam wyciągnę ten wątek, o którym wspominasz. Dam mu jeszcze czas do wieczora ;)
A co do adaptera i UBoota, w razie konieczności zapytam Hansa i ACube.

_________________
SAM440 Flex 800MHz 1GB R9250 SBLive! OS4.1 FE


Góra
 Zobacz profil  
Cytuj  
PostNapisane: niedziela, 27 gru 2020, 11:19 
Offline
Doborowy forumowicz
Doborowy forumowicz

Dołączył(a): wtorek, 17 sty 2012, 17:21
Posty: 882
Jest jakiś obraz na karcie w PCIe?


Góra
 Zobacz profil  
Cytuj  
PostNapisane: niedziela, 27 gru 2020, 20:12 
Offline
Znamienity forumowicz
Znamienity forumowicz

Dołączył(a): wtorek, 17 sty 2012, 20:57
Posty: 1058
@Mufa
Jak możesz przeczytać na Amigans trwają ostatnie szlify, drobne błędy, programiści mają wolne i takie tam. ES2.0 powinno być na początku stycznia.

@swinkamor12
Nie wiem czy się rozumiemy. Jeszcze żadnej karty do adaptera nie włożyłem. Działam etapami ;-) Zamierzam włożyć kartę ale uruchomić na drugiej, głównej (R9250). Potem użyć Rangera żeby zobaczyć czy system widzi coś za mostkiem PCI->PCIe. Wszystko korzystając z działającej, starej karty.
Potem zdobyć sterownik w wersji lite i uruchomić z nowej karty, włożonej do złącza 66MHz.

_________________
SAM440 Flex 800MHz 1GB R9250 SBLive! OS4.1 FE


Góra
 Zobacz profil  
Cytuj  
PostNapisane: poniedziałek, 28 gru 2020, 22:45 
Offline
Znamienity forumowicz
Znamienity forumowicz

Dołączył(a): wtorek, 17 sty 2012, 20:57
Posty: 1058
Kolejny etap. Dzięki uprzejmości Arka, Radeon HD 7750 jest już zamontowany i testowany . Najpierw umieściłem go w trzecim slocie a R9250 pozostał główną kartą (pierwszy slot 66MHz). Celem było sprawdzenie, co "wypluje" Ranger, bo w zasadzie byłem pewny, że Uboota zobaczę. Niestety spotkała mnie przykra niespodzianka-czarny ekran. Szybko wywaliłem kartę dźwiękową z drugiego slotu i umieściłem w nim adapter razem z RadeonemHD. Efekt niestety ten sam. Pozostało ostatnie wyjście. W miejscu starej karty , w pierwszym slocie, umieściłem ww. zestaw i....ku mojej radości prawie natychmiast pojawił się UBoot. Bez opisanego wcześniej 40 sekundowego opóźnienia. Czas startu jest może dłuższy o 2, może 3 sekundy.
Świetnie! Byłem ciekaw, do jakiego etapu wgra się system? Nie mam jeszcze zainstalowanego sterownika HD. Pasek kickstartu dojeżdża do końca i zatrzymuje się z komunikatem "loading done, now launching kickstart". To chyba dobry znak? Wydaje mi się, że teraz właśnie potrzebny jest sterownik bo zaraz ma się wyświetlić logo AmigaOS a w kickstarcie nadal jest moduł do starego Radeona.

_________________
SAM440 Flex 800MHz 1GB R9250 SBLive! OS4.1 FE


Góra
 Zobacz profil  
Cytuj  
PostNapisane: wtorek, 29 gru 2020, 14:53 
Offline
Administrator
Administrator
Avatar użytkownika

Dołączył(a): poniedziałek, 16 sty 2012, 15:14
Posty: 4058
Przemek napisał(a):
Pasek kickstartu dojeżdża do końca i zatrzymuje się z komunikatem "loading done, now launching kickstart". To chyba dobry znak? Wydaje mi się, że teraz właśnie potrzebny jest sterownik bo zaraz ma się wyświetlić logo AmigaOS a w kickstarcie nadal jest moduł do starego Radeona.


Tak, to normalny objaw. Niepotrzebnie się pospieszyłeś z przekładaniem karty, bo teraz znowu będziesz musiał wyciągnąć nową i wsadzić starą, tylko po to by przekopiować sterownik do Kickstartu i dopisać wpis do Kicklayoutu. Po czym od nowa przekładka grafiki :shifty:


Góra
 Zobacz profil  
Cytuj  
PostNapisane: wtorek, 29 gru 2020, 17:29 
Offline
Znamienity forumowicz
Znamienity forumowicz

Dołączył(a): wtorek, 17 sty 2012, 20:57
Posty: 1058
No nie za bardzo się pośpieszyłem. Wkładałem nowego Radeon od trzeciego gniazda, aż pozostało już tylko pierwsze, w którym tkwiła stara karta. No i żeby zobaczyć czy pokaże się UBoot trzeba było ją wyciągnąć. Szczególnie, że adapter jest, karta jest a sterownika nie ma. Konkluzja chyba jest taka, że to obecność dwóch kart na raz, dawała czarny ekran. No nic, całe to grzebania i tak dało mi sporo satysfakcji :lol: Oby tylko efekt był oczekiwany. Oczywiście na razie brak odzewu ze strony AEon....

_________________
SAM440 Flex 800MHz 1GB R9250 SBLive! OS4.1 FE


Góra
 Zobacz profil  
Cytuj  
PostNapisane: wtorek, 29 gru 2020, 17:48 
Offline
Administrator
Administrator
Avatar użytkownika

Dołączył(a): poniedziałek, 16 sty 2012, 15:14
Posty: 4058
Czyli rozumiem że na płycie AmigaOS 4.1 FE w wersji dla SAM440, sterownika RadeonHD v 0.XX nie ma?


Góra
 Zobacz profil  
Cytuj  
PostNapisane: wtorek, 29 gru 2020, 18:37 
Offline
Znamienity forumowicz
Znamienity forumowicz

Dołączył(a): wtorek, 17 sty 2012, 20:57
Posty: 1058
Niestety, nie...

http://wiki.amiga.org/index.php?title=RadeonHD

The RadeonHD Lite graphics driver software has been currently licenced to Hyperion Entertainment CVBA for inclusion on the AmigaOne X1000 and AmigaOne 500 versions of AmigaOS 4.1 Final Edition CD only. Hyperion Entertainment CVBA have not licenced any other version of the RadeonHD driver, including either the RadeonHD v1, v2 or v3 and therefore can only distribute the RadeonHD Lite version with AmigaOS.


ACube Systems s.r.l has been granted permission to distribute the RadeonHD Lite with their AmigaOne 500 systems.

_________________
SAM440 Flex 800MHz 1GB R9250 SBLive! OS4.1 FE


Góra
 Zobacz profil  
Cytuj  
PostNapisane: wtorek, 29 gru 2020, 20:28 
Offline
Administrator
Administrator
Avatar użytkownika

Dołączył(a): poniedziałek, 16 sty 2012, 15:14
Posty: 4058
Ok. Dzięki za przypomnienie. To już sześć lat od wydania AOS 4FE, nie pamiętam już wszystkiego, zwłaszcza że ISO dla SAM440 przeglądałem pewnie jeden raz, bo i nie mając sprzętu nie miałem potrzeby. Myślałem że skoro ten sterownik to coś w rodzaju wersji demo, to być może nie ograniczali jego dostępności do konkretnych platform.


Góra
 Zobacz profil  
Cytuj  
PostNapisane: środa, 30 gru 2020, 18:53 
Offline
Ultra forumowicz
Ultra forumowicz

Dołączył(a): poniedziałek, 16 sty 2012, 22:11
Posty: 1558
Przemek napisał(a):
Niestety, nie...

http://wiki.amiga.org/index.php?title=RadeonHD

The RadeonHD Lite graphics driver software has been currently licenced to Hyperion Entertainment CVBA for inclusion on the AmigaOne X1000 and AmigaOne 500 versions of AmigaOS 4.1 Final Edition CD only. Hyperion Entertainment CVBA have not licenced any other version of the RadeonHD driver, including either the RadeonHD v1, v2 or v3 and therefore can only distribute the RadeonHD Lite version with AmigaOS.
ACube Systems s.r.l has been granted permission to distribute the RadeonHD Lite with their AmigaOne 500 systems.


Przypuszczam, że SAM440ep i SAM440EP-Flex nie miały sterownika RadeonHD ponieważ nie posiadają złącza PCI-E tylko stare złącze PCI 33Mhz lub/i 66Mhz.
Natomiast AmigaOne 500 & Sam 460 - mają złącze PCI-E dlatego też mają WSPÓLNE ISO AmigaOS41FE a w nim sterownik RadeonHD.

Karty RadeonHD/RadeonX mają w 99% złącze PCI-E choć posiadam:

- RadeonHD 2400 PCI 256 mb
- RadeonX1550 PCI 256 mb VisionTek - od takiej karty Hans zaczynał pisać sterownik: http://hdrlab.org.nz/projects/amiga-os- ... hd-driver/


Góra
 Zobacz profil  
Cytuj  
PostNapisane: poniedziałek, 4 sty 2021, 19:58 
Offline
Administrator
Administrator

Dołączył(a): poniedziałek, 16 sty 2012, 13:40
Posty: 220
Lokalizacja: okolice Lublina
Przemek napisał(a):
Oczywiście na razie brak odzewu ze strony AEon....


Jak się odezwą to daj znać. Wysłałem do nich maila odnośnie ES.

_________________
AmigaONE X5000/20


Góra
 Zobacz profil  
Cytuj  
PostNapisane: piątek, 8 sty 2021, 17:24 
Offline
Administrator
Administrator
Avatar użytkownika

Dołączył(a): poniedziałek, 16 sty 2012, 15:14
Posty: 4058
tchomasz napisał(a):
Przemek napisał(a):
Oczywiście na razie brak odzewu ze strony AEon....


Jak się odezwą to daj znać. Wysłałem do nich maila odnośnie ES.


No i co odpisał? Pytam bo w sumie też miałbym sprawę do niego, ale znając jego "kontaktowość" nie wiem czy warto tracić czas na pisanie maili.


Góra
 Zobacz profil  
Cytuj  
Wyświetl posty nie starsze niż:  Sortuj wg  
Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 41 ]  Przejdź na stronę 1, 2, 3  Następna strona

Strefa czasowa: UTC + 1


Kto przegląda forum

Użytkownicy przeglądający ten dział: Google [Bot] i 1 gość


Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Skocz do:  
cron
Powered by phpBB® Forum Software © phpBB Group
Przyjazne użytkownikom polskie wsparcie phpBB3 - phpBB3.PL
phpBB SEO