Forum AmigaOne Zone

Forum użytkowników Amigi i nie tylko
Teraz jest środa, 17 sty 2018, 16:43

Strefa czasowa: UTC + 1 [ DST ]




Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 13 ] 
Autor Wiadomość
 Tytuł: Mplayer 6.5.7
PostNapisane: niedziela, 9 sie 2015, 16:34 
Offline
Administrator
Administrator
Avatar użytkownika

Dołączył(a): poniedziałek, 16 sty 2012, 16:14
Posty: 2876
Od kilku tygodni dostępna jest nowa wersja Mplayera. Fakt ten jest chyba mało znany, gdyż autor z niewiadomych względów nie zdecydował się na upload do OS4Depot czy chocby Aminetu, tylko wrzucił archiwum na http://database-org.com/index.php gdzie niestety aby coś pobrać trzeba założyć konto i się zalogować.

Poniżej lista zmian:
Kod:
Version 6.5.6
Video outputs, now know if ASL windows are open, and do not render on top the ASL window.
Fixed: vo_comp: when starting mplayer in fullscreen mode, backfill window did not work.
Fix for about window, in full-screen mode, as it was painted over.
conf/input.conf now has mapped keys for dvdnav.
Menu, now as dvdnav option, (you most disable cahce in config to use this option)
vo_comp_yuv now has the same changes as vo_comp_yuv2.
Lots of code missing in preinit() on p96_pip, hope this helps ;-)
p96_pip: Wrong BytesPerRow fix.
p96_pip: replaced p96LockBitmap() with LockBitmap(), (it's two jump's faster, I think)
p96_pip: replaced WaitTOF() with WaitBOVP( ViewPort )
vo_comp_yuv2: extra pageflip, when going fullscreen or window, for low fps videos.
Changed timeing in audio output AHI_DEV
Rewrote buffering in AHI_DEV
AHI playback process should now, stop if movie is paused, or buffer is empty.
Changed video output priority, now \\\"p96_pip\\\" comes before \\\"comp\\\"

Version 6.5.5
Fixed: NODRI video option.
(To disable direct rendering on codecs with broken DRI support.)
Updated readme from Samo79 (thanks)
Fixed: Graphics.library check in CGX_WPA.
Renamed CGX_WPA to WPA on AmigaOS4.
vo_comp_vuv2: Removed some extra layer locking, some times used 2 times.
vo_comp_yuv2: Found a AltiVec version of memcpy, now used by vo_comp_yuv2
vo_comp_yuv2: Layerlocks & DoHookClipRects are NOW only used when needed.
vo_comp_yuv2: Removed a few compiler warnings, it started to getting hard to find the real errors :-)
vo_comp_yuv2: tried to unroll a few loops.

Version 6.5.4
Fixed: Picasso96 OSD
Fixed: Picasso96 Menu
Checked to see if p96 white stripes bug fix was missing
RadeonHD video outputs is now disabled, If you don't have a RadeonHD gfx card.
Right Click Mouse menu bug fix.
All CyberGfx stuff removed from cgx_wpa (pure graphics library)

Mplayer 6.5.3
6.5.0: Menus
6.5.1: FFMPEG 2.5 (64Bit fix)
6.5.2: Drag and Drop
6.5.2: new: Missing 3gp in ASL bug fix.
New: Adding Screenshotdir and EXTPATTERN
New: Menu: cursor disappear: bug fix
New: Drag and Drop: bug fix
New: Fixed Screenshot, problem

Mplayer 6.5.2
6.5.0 Menus
6.5.1 FFMPEG 2.5 (64Bit fix)
New: Drag and Drop
New: Missing 3gp in ASL bug fix.

Mplayer 6.5.1
6.5.0: Menus
New: FFMPEG 2.5 (64Bit fix)

MPlayer 6.5
New: Menus


Udostępnij dla FacebookUdostępnij dla TwitterUdostępnij dla Google+
Góra
 Zobacz profil  
Cytuj  
PostNapisane: poniedziałek, 10 sie 2015, 16:23 
Offline
Administrator
Administrator
Avatar użytkownika

Dołączył(a): poniedziałek, 16 sty 2012, 16:14
Posty: 2876
Nowy Mplayer niestety nie odtwarza mi poprawnie filmów Avi Mjpeg stworzonych przy użyciu Hollywood (odgrywa tylko dźwięk). Dlatego dobrze jest gdzieś w odwodzie zostawić sobie starszą wersję.


Góra
 Zobacz profil  
Cytuj  
PostNapisane: poniedziałek, 10 sie 2015, 19:01 
Offline
Doborowy forumowicz
Doborowy forumowicz
Avatar użytkownika

Dołączył(a): wtorek, 17 sty 2012, 13:28
Posty: 934
Bo to jest wersja do testów, dlatego cuda-wianki z logowaniem żeby pobrać. Ja bym sobie odpuścił tę wersję i poczekał na oficjalną.


Góra
 Zobacz profil  
Cytuj  
PostNapisane: poniedziałek, 17 sie 2015, 10:21 
Offline
Administrator
Administrator
Avatar użytkownika

Dołączył(a): poniedziałek, 16 sty 2012, 16:14
Posty: 2876
Program jest już na Depocie. Sprawdzę czy cokolwiek się zmieniło w kwestii odtwarzania filmów wyprodukowanych w Hollywood.


Góra
 Zobacz profil  
Cytuj  
PostNapisane: niedziela, 24 gru 2017, 14:16 
Offline
Administrator
Administrator
Avatar użytkownika

Dołączył(a): poniedziałek, 16 sty 2012, 16:14
Posty: 2876
Po dwóch latach przerwy mamy nowego Mplayera, a konkretnie MickJT MPlayera, który bazuje na MPlayerze 1.3.0 (opartym o FFMPEG 3) czyli ostatnim stabilnym release dla "wiodących proszków".


Góra
 Zobacz profil  
Cytuj  
PostNapisane: niedziela, 24 gru 2017, 15:11 
Offline
Administrator
Administrator
Avatar użytkownika

Dołączył(a): poniedziałek, 16 sty 2012, 16:14
Posty: 2876
Mufa napisał(a):
Nowy Mplayer niestety nie odtwarza mi poprawnie filmów Avi Mjpeg stworzonych przy użyciu Hollywood (odgrywa tylko dźwięk). Dlatego dobrze jest gdzieś w odwodzie zostawić sobie starszą wersję.


No i najnowsza odsłona już mi się podoba, gdyż nie ma problemu, którego wówczas zgłaszałem.


Góra
 Zobacz profil  
Cytuj  
PostNapisane: niedziela, 24 gru 2017, 20:07 
Offline
Znamienity forumowicz
Znamienity forumowicz

Dołączył(a): poniedziałek, 16 sty 2012, 23:11
Posty: 1035
Kawał dobrej roboty płynnie i stabilnie.
Zawiera kod z poprzednich wersji: LiveForIt-MPlayer i afxgroup - super !!!


MickJT-MPlayer 1.0
==================

* Based on MPlayer 1.3.0 (ffmpeg 3.0)
* Merged AmigaOS code from LiveForIt-MPlayer
* Kept the Workbench startup code from afxgroup


Góra
 Zobacz profil  
Cytuj  
PostNapisane: wtorek, 26 gru 2017, 00:37 
Offline
Elitarny forumowicz
Elitarny forumowicz
Avatar użytkownika

Dołączył(a): piątek, 20 sty 2012, 23:31
Posty: 559
Powiem tylko, że daje radę, ten sam film 1280x720x24fps odgrywa przy jakichś 38% zajętości procka, podczas gdy Emotion ten sam film odgrywa od odkoło 40 nawet do 100%. Cały filmik odegrał się bardzo ładnie i płynnie. Jak dla mnie to najlepsze co mogliśmy dostać na gwiazdkę w tych okolicznościach przyrody. Zmieniam swoją domyślną odgrywaczkę filmów : ).

Poprawka, nie 38%, jest pomiędzy 25 a 41, w najgorętszych momentach dobija do 61%.

_________________
AmigaOne X5000/020, Sapphire Radeon R9 270X Toxic, 2GB RAM.
Amiga1200/060 32MB RAM
Obrazek


Góra
 Zobacz profil  
Cytuj  
PostNapisane: wtorek, 26 gru 2017, 09:17 
Offline
Znamienity forumowicz
Znamienity forumowicz

Dołączył(a): poniedziałek, 16 sty 2012, 23:11
Posty: 1035
Autor pracuje już nad poprawkami zauważonych i zgłoszonych błędów w tym wątku:

http://www.amigans.net/modules/xforum/v ... 96&forum=3

PS.
Można już pobierać testowe wersja poprawkowe (Generic i Altivec): Post#1 z w/w linku.
Pliki zawierają licznik [Upload #] - łatwiej zauważyć nową poprawkę :)


Góra
 Zobacz profil  
Cytuj  
PostNapisane: wtorek, 26 gru 2017, 17:37 
Offline
Administrator
Administrator
Avatar użytkownika

Dołączył(a): poniedziałek, 16 sty 2012, 16:14
Posty: 2876
Radek Cz napisał(a):
Powiem tylko, że daje radę, ten sam film 1280x720x24fps odgrywa przy jakichś 38% zajętości procka, podczas gdy Emotion ten sam film odgrywa od odkoło 40 nawet do 100%. Cały filmik odegrał się bardzo ładnie i płynnie. Jak dla mnie to najlepsze co mogliśmy dostać na gwiazdkę w tych okolicznościach przyrody. Zmieniam swoją domyślną odgrywaczkę filmów : ).

Poprawka, nie 38%, jest pomiędzy 25 a 41, w najgorętszych momentach dobija do 61%.


Potwierdzam że ta odsłona jest zdecydowanie wydajniejsza od poprzedniej. W przypadku przeciętnego filmu HD Ready (pisząc przeciętnego nie mam na myśli ultra lekkiego kodeka typu wspominany na tym forum kilkukrotnie trailer Kung Fu Panda) zajętość procesora w przypadku wersji Altivec, potrafi u mnie spaść nawet do poziomu dwudziestu kilku procent, a muszę tutaj dodać że ostatnimi czasy nawet w trakcie bezczynności systemu, CPU_Temp_Docky pokazuje mi zajętość między 5 a 10%.

EDIT
Prometheus trailer, czyli swego rodzaju miernik w amiświecie, będący bohaterem benchmarków ale też wyznacznikiem tego czy Amiga jest w stanie wyświetlać filmy FullHD (zdaje się że było jakieś bounty związane z tym trailerem), działa prawie idealnie. Obraz nie rwie, nie klatkuje, dźwięk może w dwóch fragmentach rozjeżdża się z obrazem na sekundę, lecz potem wraca do normy, więc nie jest to rozjazd na stałe, który objawia się wówczas gdy naprawdę brakuje wydajności. Zajętość procesora fragmentami dochodzi do 100% ale też długimi momentami oscyluje wokół 80%. Słowem po tym co widziałem zaczynam wierzyć w to że gdyby udało się uzyskać jeszcze odrobinę optymalizacji, to na A1 X1000 byłoby możliwe normalne odtwarzanie filmów FullHD nawet bez wsparcia UVD. Dodam że już teraz jest to możliwe w przypadku części produkcji np. znany film Bick Buck Bunny 1080p w divx odtwarza się całkowicie normalnie gdzie wskaźnik zajętości procesora nigdy nie dobija do 100%. A trzeba przyznać że w przeciwieństwie do Prometheusa (który co prawda ma 1920 pikseli w poziomie, lecz w pionie jest trochę za bardzo panoramiczny), tutaj mamy do czyniena ze standardową rozdzielcozścią FullHD (tyle że z "lżejszym" kodekiem).


Góra
 Zobacz profil  
Cytuj  
PostNapisane: środa, 3 sty 2018, 12:36 
Offline
Administrator
Administrator
Avatar użytkownika

Dołączył(a): poniedziałek, 16 sty 2012, 16:14
Posty: 2876
Na Depocie, jest już wersja 1.01


Góra
 Zobacz profil  
Cytuj  
PostNapisane: środa, 3 sty 2018, 12:58 
Offline
Doborowy forumowicz
Doborowy forumowicz
Avatar użytkownika

Dołączył(a): wtorek, 17 sty 2012, 13:28
Posty: 934
A jak uzyskać wskazanie liczby klatek? Tu nie ma konsoli chyba, jest scalony player z GUI?


Góra
 Zobacz profil  
Cytuj  
PostNapisane: środa, 3 sty 2018, 16:27 
Offline
Administrator
Administrator
Avatar użytkownika

Dołączył(a): poniedziałek, 16 sty 2012, 16:14
Posty: 2876
adam napisał(a):
A jak uzyskać wskazanie liczby klatek? Tu nie ma konsoli chyba, jest scalony player z GUI?


Możesz odpalić Mplayera z konsoli to Ci będzie wyświetlał loga a po zakończeniu filmu wskaże liczbę FPS. Możesz też podpiąć to pod MplayerGUI i o ile nie zaptaszkujesz "no CLI output" to też Ci pokaże wyniki w konsoli. Do hardcorowych testów polecam ten najnowszy film z bloga Trevora, jest w zabójczym kodeku H264 High o dużym bitrate 28840 i równie dużej liczbie klatek na sekundę 60fps. Tego filmu ewidentnie nie da się ruszyć bez UVD. Na mojej X1000 osiąga lediwe 17fps. Natomiast wspomniany wcześniej stawiany za modelowy film Prometheus ma nominalne klatkowanie 23,98fps a MPlayer pokazuje mi w konsoli 23fps, czyli jak pisałem poprzednio, jest już prawie idealnie.


Góra
 Zobacz profil  
Cytuj  
Wyświetl posty nie starsze niż:  Sortuj wg  
Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 13 ] 

Strefa czasowa: UTC + 1 [ DST ]


Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 2 gości


Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Skocz do:  
Powered by phpBB® Forum Software © phpBB Group
Przyjazne użytkownikom polskie wsparcie phpBB3 - phpBB3.PL
phpBB SEO