Forum AmigaOne Zone

Forum użytkowników Amigi i nie tylko
Teraz jest środa, 24 paź 2018, 04:29

Strefa czasowa: UTC + 1 [ DST ]




Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 18 ]  Przejdź na stronę 1, 2  Następna strona
Autor Wiadomość
PostNapisane: wtorek, 8 maja 2018, 12:28 
Offline
Znamienity forumowicz
Znamienity forumowicz
Avatar użytkownika

Dołączył(a): wtorek, 17 sty 2012, 13:28
Posty: 1071
Tak sobie coś dłubię na temat zapowiadanej książki i jest to okazja do uruchamiania i używania rzeczy niedotykanych dawno przeze mnie.
Utknąłem w rzeczach podstawowych. Pierwsze dwie wątpliwości.

1. Edytor ikon (systemowy)
Po uruchomieniu zamraża system, konieczny jest twardy reset. Konsultowałem to z innym użytkownikiem OS 4 - jemu działa, ale wczytane ikonki mają przekłamania kolorów. Jak z tym jest u was?
2. Po zabawach z tematami WB został mi inny kursor. Próbowałem go zmienić z poziomu Prefs -> Pointer i nic się nie dzieje. Wiem, jakie są nazwy plików i wiem o katalogu sys:env:archive, ale.. no właśnie jak to zrobić, żeby zmiana zadziałała?


Udostępnij dla FacebookUdostępnij dla TwitterUdostępnij dla Google+
Góra
 Zobacz profil  
Cytuj  
PostNapisane: wtorek, 8 maja 2018, 20:49 
Offline
Administrator
Administrator
Avatar użytkownika

Dołączył(a): poniedziałek, 16 sty 2012, 16:14
Posty: 3221
adam napisał(a):
Tak sobie coś dłubię na temat zapowiadanej książki i jest to okazja do uruchamiania i używania rzeczy niedotykanych dawno przeze mnie.
Utknąłem w rzeczach podstawowych. Pierwsze dwie wątpliwości.

1. Edytor ikon (systemowy)
Po uruchomieniu zamraża system, konieczny jest twardy reset. Konsultowałem to z innym użytkownikiem OS 4 - jemu działa, ale wczytane ikonki mają przekłamania kolorów. Jak z tym jest u was?


IconEdit powinien działać. Trudno mi powiedzieć dlaczego u Ciebie nie działa. Warto jednak zauważyć że nosi numerek 44.20. Jak wiadomo 44 to numeracja dla systemu AmigaOS 3.5 (45.xx = AOS 3.9, 50.xx = AOS 4.0 Pre release, 52.xx, AOS 4.0, 53.xx = AOS 4.1, 54.xx = AOS 4.2). Jest to więc jeden z nielicznych elementów systemu, który nie został przepisany na PowerPC i pomimo daty pliku z okresu obowiązywania AmigaOS 4 28.02.2006, to jest nadal narzędzie dla 68k. Jak wiadomo w czasach AOS 3.5 nikt nie znał standardu ikon dla AmigaOS 4.1 i 4.0 (zresztą pierwsze wersjie Pre release, też miały jeszcze stary standard Glowicon), to też trudno się dziwić że program niepoprawnie rozpoznaje ikony w nieznanym sobie standardzie i przekłamuje kolory.

Jak wiadomo były kiedyś próby zastąpienia systemowego edytora ikon nowym (m. in. kolega Heextreme coś tam próbował robić w ramach bounty) ale nic z tego nie wyszło. Jako że i tak najwygodniej jest używać do tego celu nowoczesnych programów typu Gimp, to nikt tego już potem nie ruszał i myślę że ma to niski priorytet. To narzędzie można więc traktować tylko jako edytor ikon dla starszych wersji systemu, z którymi to standardami jak wiadomo AmigaOS 4 jest kompatybilny w dół.
Na marginesie myślę że taki zamiennik to by była idealna rzecz do dołączenia do pakietu Enhancer Software, napewno bardziej użyteczna niż podróba AmiDocka czy Exchange.


Góra
 Zobacz profil  
Cytuj  
PostNapisane: wtorek, 8 maja 2018, 22:41 
Offline
Znamienity forumowicz
Znamienity forumowicz
Avatar użytkownika

Dołączył(a): wtorek, 17 sty 2012, 13:28
Posty: 1071
Cytuj:
Jak wiadomo w czasach AOS 3.5 nikt nie znał standardu ikon dla AmigaOS 4.1 i 4.0 (zresztą pierwsze wersjie Pre release, też miały jeszcze stary standard Glowicon), to też trudno się dziwić że program niepoprawnie rozpoznaje ikony w nieznanym sobie standardzie i przekłamuje kolory.

Rozumiem taką argumentację jak podałeś odnośnie przekłamania kolorów, ale u mnie zamraża się po uruchomieniu bez wczytywania ikon. Na pusto. Jestem zdziwiony że to działa u ciebie, bo system masz jeszcze nowszy.
Czyli to zostawiamy. To poczekam jeszcze na próby z ustawieniem kursora, dopóki tego nie wyjaśnimy to nie będę wyciągał kolejnych rzeczy.


Góra
 Zobacz profil  
Cytuj  
PostNapisane: wtorek, 15 maja 2018, 13:54 
Offline
Znamienity forumowicz
Znamienity forumowicz
Avatar użytkownika

Dołączył(a): wtorek, 17 sty 2012, 13:28
Posty: 1071
Czyli rozumiem że nie da się ustawić kursora z poziomu Prefs? Nie chce być oskarżany po publikacji o sianie nieprawdy.


Góra
 Zobacz profil  
Cytuj  
PostNapisane: wtorek, 15 maja 2018, 21:59 
Offline
Administrator
Administrator
Avatar użytkownika

Dołączył(a): poniedziałek, 16 sty 2012, 16:14
Posty: 3221
adam napisał(a):
Czyli rozumiem że nie da się ustawić kursora z poziomu Prefs? Nie chce być oskarżany po publikacji o sianie nieprawdy.


32-bitowe kursory wprowadzono wraz systemem AmigaOS 4.0 FE, a więc lat już temu 12. Jako że ja co do zasady mie zwykłem zmieniać tematów WB, czy samych kursorów, to też nie bardzo mam papiery na jednoznaczną odpowiedź w tej kwestii. Jednakże o ile czegoś nie pomyliłem i o ile pamięć mnie nie zawodzi, to od początku było tak że musiałeś po prostu przekopiować samemu def_pointer do odpowiedniego katalogu w sys:prefs/env. Wydaje mi się przy tym że nadal zachowano możliwość stosowania klasycznego pointera, którego możesz zapisać po staremu z preferencji wskaźnika.

Szczerze powiedziawszy nie mam teraz czasu by przyjrzeć się sprawie i samemu to zweryfikować, bo niemal ustawicznie ostatnio siedzę w pracy (teraz też), może w niedzielę uda mi się przysiąść do Amigi na godzinę czy dwie.


Góra
 Zobacz profil  
Cytuj  
PostNapisane: czwartek, 20 wrz 2018, 13:19 
Offline
Znamienity forumowicz
Znamienity forumowicz
Avatar użytkownika

Dołączył(a): wtorek, 17 sty 2012, 13:28
Posty: 1071
1. Nigdy, w żadnej wersji TuneNet, nie uświadczyłem okładki. Jaki może być powód?
2. Do zrzutów używam systemowego SGraba, ale niezależnie od wybranej opcji zawsze zapisuje jako ILBM. Czy tak ma być?


Góra
 Zobacz profil  
Cytuj  
PostNapisane: czwartek, 20 wrz 2018, 15:38 
Offline
Administrator
Administrator
Avatar użytkownika

Dołączył(a): poniedziałek, 16 sty 2012, 16:14
Posty: 3221
Ja nie mam problemu z okładkami Tunenet, jak i zapisywaniem obrazów SGraba do innych formatów. Ewidentnie czegoś na Twoim dysku musi brakować.

Zastanawiam się czy masz w systemie jpeg.library?


Góra
 Zobacz profil  
Cytuj  
PostNapisane: sobota, 22 wrz 2018, 18:22 
Offline
Administrator
Administrator
Avatar użytkownika

Dołączył(a): poniedziałek, 16 sty 2012, 16:14
Posty: 3221
Nie otrzymałem odpowiedzi co do tej biblioteki, ale zastanawiam się mocno czy powodem Twoich problemów nie jest aby skopany Arexx, gdyż Tunenet korzysta z niego chyba m.in. przy wyświetlaniu okładek płyt i wydaje mi się że SGrab też go wykorzystuje. Na Twoim miejscu skopiowałbym rexx'owe biblioteki z płytki AmigaOS 4.1 FE na partycję systemową. Ewentualnie w dalszej kolejności skopiowałbym datatypy.


Góra
 Zobacz profil  
Cytuj  
PostNapisane: sobota, 22 wrz 2018, 18:31 
Offline
Aktywny forumowicz
Aktywny forumowicz
Avatar użytkownika

Dołączył(a): piątek, 20 sty 2012, 06:09
Posty: 404
Cytuj:
Nie otrzymałem odpowiedzi co do tej biblioteki, ale zastanawiam się mocno czy powodem Twoich problemów nie jest aby skopany Arexx, gdyż Tunenet korzysta z niego chyba m.in. przy wyświetlaniu okładek płyt i wydaje mi się że SGrab też go wykorzystuje. Na Twoim miejscu skopiowałbym rexx'owe biblioteki z płytki AmigaOS 4.1 FE na partycję systemową. Ewentualnie w dalszej kolejności skopiowałbym datatypy.


Nie trzeba datatypów ani ARexxa do SGraba. :D Sam go mam na A1200/3.1 i działa dobrze i zgrywa PNG, przy czym nie mam ani RexxMast uruchomionego, ani datatypu PNG. @Adam: Jesteś pewien, że zaznaczyłeś dobrze opcję "zgrywania do PNG"?

_________________
Robert "MasterMax" Szacki - Inner Power Software


Góra
 Zobacz profil  
Cytuj  
PostNapisane: sobota, 22 wrz 2018, 19:39 
Offline
Administrator
Administrator
Avatar użytkownika

Dołączył(a): poniedziałek, 16 sty 2012, 16:14
Posty: 3221
Hextreme napisał(a):

Nie trzeba datatypów ani ARexxa do SGraba.


Nie chcę się spierać bo nie siedzę teraz przed Amigą i nie mam wglądu do dokumentacji, ale za recenzją starej wersji 68k:


SGrab wymaga systemu operacyjnego 3.0+, Amigi z procesorem 68020+ i easyrexx.library arexx.


Z kolei w innej starej recenzji wyczytałem że poza IFF i JPEG, które są wbudowane w program zapis do innych formatów odbywa się za pośrednictwem datatypów. Oczywiście nie wykluczam że te informacje są nieaktualne, niemniej szukając jakichś tropów na rozwiązanie nietypowego problemu Adama, myślę że nie zaszkodzi zacząć od skopiowania tych właśnie elementów z płyty AmigaOS 4.


Góra
 Zobacz profil  
Cytuj  
PostNapisane: sobota, 22 wrz 2018, 19:41 
Offline
Aktywny forumowicz
Aktywny forumowicz
Avatar użytkownika

Dołączył(a): piątek, 20 sty 2012, 06:09
Posty: 404
ARexx jest opcjonalny. Za to zapis do JPG wymaga, tak jak wspomniałeś jpeg.library. Ale zapis do PNG i IFF odbywa się zwyczajnie.

_________________
Robert "MasterMax" Szacki - Inner Power Software


Góra
 Zobacz profil  
Cytuj  
PostNapisane: sobota, 22 wrz 2018, 21:10 
Offline
Aktywny forumowicz
Aktywny forumowicz
Avatar użytkownika

Dołączył(a): piątek, 20 sty 2012, 06:09
Posty: 404
Żeby nie być gołosłownym zrzuciłem ekran mojego Workbencha za pomocą SGraba 1.22 bezpośrednio do PNG. Załączam tutaj:

Obrazek

_________________
Robert "MasterMax" Szacki - Inner Power Software


Góra
 Zobacz profil  
Cytuj  
PostNapisane: niedziela, 23 wrz 2018, 11:39 
Offline
Znamienity forumowicz
Znamienity forumowicz
Avatar użytkownika

Dołączył(a): wtorek, 17 sty 2012, 13:28
Posty: 1071
Nie sprawdziłem tego jeszcze dlatego nie pisałem, ale widzę że w międzyczasie doszły nowe opcje.
Wiem ze SGrab czasem wywali błąd AREXX-a (ale nie zakłóca to działania). Ale wiem też, że poprzednio miałem A1 z Altivecem, w sumie mam trzecią wersję systemu i zawsze tak miałem.
Sprawdzę sugestie wyżej, napiszę.


Góra
 Zobacz profil  
Cytuj  
PostNapisane: niedziela, 23 wrz 2018, 20:03 
Offline
Znamienity forumowicz
Znamienity forumowicz
Avatar użytkownika

Dołączył(a): wtorek, 17 sty 2012, 13:28
Posty: 1071
Sprawdziłem - co do SGraba to był mój błąd. Przy robieniu zrzutu przez schowek niezależnie od wybranego rozszerzenia pliku (przed i po) zawsze zapisuje do ILBM.
Co do Tuneneta - wymieniłem pliki AREXX-a (sztuk 4) i bez rezultatu. Możliwe, że to coś równie prostego do wyjaśnienia. Rozumiem, że okładki działają tez dla utworów z radia?


Góra
 Zobacz profil  
Cytuj  
PostNapisane: wtorek, 25 wrz 2018, 09:43 
Offline
Administrator
Administrator
Avatar użytkownika

Dołączył(a): poniedziałek, 16 sty 2012, 16:14
Posty: 3221
adam napisał(a):
Rozumiem, że okładki działają tez dla utworów z radia?


Dzisiaj przetestowałem ze 6 - 7 stacji radiowych i w ani jednym wypadku nie widziałem okładki. Postanowiłem też przy okazji bardziej przetestować płyty mp3. Pisałem bowiem wcześniej nie raz że płyty z okładkami u mnie działają, ale to tak na zasadzie że zdarzyło mi się to u siebie widzieć. Teraz podszedłem do sprawy bardziej metodycznie i mogę stwierdzić że okładki działają w mniejszości moich płyt, tak mniej więcej na 15 albumów, które przetestowałem okładki wyświetliły się w 5.

Możliwe więc że po prostu miałeś pecha i trafiałeś nie na te albumy co trzeba. Postaram się jeszcze przetestować czy w przypadku płyt, których TuneNet nie potrafi otwierać okładek, uda mi się je wyświetlić na odtwarzaczu z PC, czy po prostu te płyty już tak mają.

Edit:
No więc wykonałem szybki test na PC, ze względu na brak czasu na bardzo wąskiej grupie albumów. Konkretnie załadowałem do VLC trzy płyty, dwie takie gdzie TuneNet poległ z okładkami i jedną, gdzie okładkę wyświetlił. W przypadku testów pod Windows wynik był nieco lepszy, tam udało się wyświetlić okładkę dla dwóch płyt, a dla jednej nie. Pozwala to jednak stwierdzić że w jakimś tam stopniu TuneNet jest w tym względzie upośledzony wobec VLC i że nie wszystkie okładki, kţóre działają na typowym wyświetlaczu z peceta uda się wyświetlić na Amidze.


Góra
 Zobacz profil  
Cytuj  
Wyświetl posty nie starsze niż:  Sortuj wg  
Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 18 ]  Przejdź na stronę 1, 2  Następna strona

Strefa czasowa: UTC + 1 [ DST ]


Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 2 gości


Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Skocz do:  
cron
Powered by phpBB® Forum Software © phpBB Group
Przyjazne użytkownikom polskie wsparcie phpBB3 - phpBB3.PL
phpBB SEO